В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lilofun
lilofun
09.07.2022 06:42 •  Информатика

1) написать программу, которая считает сумму, в pascal abc 1+1/2+1/3++1/28, используя цикл while 2) написать программу, которая считает сумму, в pascal abc 1+1/2+2+1/3+3+1/+1/10+10, используя цикл while 3) написать программу, которая считает сумму, в pascal abc 1-2+3-4+, используя цикл while решите хотя бы две,

Ответ:
сергей1105
сергей1105
09.10.2020 14:09

1)

var i,a:integer;

c:real;

begin

i:=1;

c:=0;

while i<=28 do begin

c:=c+1/i;

i:=i+1;

end;

writeln(c);

end.

2)

var i,a:integer;

c:real;

begin

i:=2;

c:=1;

while i<=10 do begin

c:=c+1/i+i;

i:=i+1;

end;

writeln(c);

end.

3)

var c,i:integer;

begin

c:=0;

i:=1;

while i<=28 do begin

if i mod 2 = 1 then c:=c+i else c:=c-i;

i:=i+1;

end;

writeln(c);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?