В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ilyaderkach98
ilyaderkach98
18.09.2022 07:24 •  Информатика

Составьте программу которая заполняет массив а 1..8 случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями

Ответ:
mrazamar0kk
mrazamar0kk
09.10.2020 14:05

program massive;

const n=8;

var a:array[1..n]of integer;

sum,k,i:integer;

begin

sum:=0;

k:=0;

//заполнение массива

for i:=1 to n do

begin

a[i]:=random(10);

end;

if a[i] mod 2=0 then inc(k)

esle sum:=sum+a[i];

writeln('кол-во четных элементов =', k);

writeln('Сумма нечетных элементов =',sum);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?