В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу: упорядочьте элементы строк массива по убыванию модулей элементов методом двоичного включения (pascal)

Ответ:
Werevolk1
Werevolk1
17.08.2020 07:18

#include <iostream>

#include <algorithm>

#include <vector>

#include <random>

 

int main()

{

 srand(time(NULL));

 const int n = 20;

 std::vector<int> arr(n);

 for(int i = 0;i < n;i++)

 {

     arr[i] = -20 + rand() % 40;

 }

 

 for(const int i : arr)

 {

     std::cout << i << " ";

 }

 std::cout << std::endl;

 

 std::sort(arr.begin(),arr.end(),[](int a,int b){ return abs(a) > abs(b); });

 for(const int i : arr)

 {

     std::cout << i << " ";

 }

 

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?