В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
katka55555
katka55555
26.01.2022 09:54 •  Информатика

Можете написать программу выводящую на экран строку матрицы сумма элементов в которой максимальна на python

Ответ:
timatimakarov
timatimakarov
27.08.2020 12:00

import random as r

def function(n, m):

   matrix = [[r.randint(0, 100) for x in range(n)] for y in range(m)]

   max_sum = []

   for q in matrix:

       max_sum.append(sum(q))

       print("{} -- {}".format(q, sum(q)))

   id_max_el = max_sum.index(max(max_sum))

   print(

       "\nСтрока матрицы сумма элементов в которой максимальна -- {}".format(

           matrix[id_max_el]))

z = int(input("Сколька столбцов?: "))

c = int(input("Сколька строк?: "))

function(z, c)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?