В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vika2947
Vika2947
03.09.2020 19:02 •  Информатика

Дан массив из 10 чисел. определите, сколько элементов этого массива имеют минимальное значение. (паскаль)

Ответ:
Аляяяя0604
Аляяяя0604
10.09.2020 22:59

Если одномерный массив, то:

program min;

var a:array[1..10] of integer;

i,min,k:integer;

begin

writeln('Введите элементы массива');

for i:=1 to 10 do

readln(a[i]);

min:=a{1];

for i:=1 to 10 do

if a{i]<min

then min:=a{i};

for i:=1 to 10 do

if a{i]=min

then k:=k+1;

writeln('Всего элементов с минимальным значением =',k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?