В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nastia04102015
nastia04102015
17.03.2023 13:15 •  Информатика

Напишите программу которая определяет верно ли что введённое число содержит цифру 3 или цифру 5
формат ввода: программа получает на вход натуральное число n
формат вывода: программа должна вывести yes или no.​

Ответ:
EstrWite
EstrWite
09.10.2020 12:38

program treeorfive

var b, n : integer;

begin

readln(n);

b:=0;

while (n>0) and (b=0) do

if (n mod 10=5) or (n mod 10=3)then b:=1

                              else if (n div 10=5) or (n div 10=3) then b:=1

                                                                   else n:=n div 10;

if (b=1) then write('YES')

        else write('NO')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?