В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dodess
dodess
14.09.2020 01:11 •  Информатика

На с++ с циклом white на вход программы подается 10 чисел. выведите в столбик для каждого из них число, равное удвоенному квадрату первоначального числа. формат входных данных в единственной строке через пробел вводятся 10 целых чисел, по модулю не превосходящих 1000. формат выходных данных необходимо вывести 10 строк, в каждой из которых будет по одному числу — результат преобразования исходных чисел. примеры входные данные выходные данные 1 10 2 4 2 5 3 6 101 11 2 200 8 32 8 50 18 72 20402 242

Ответ:
nikolya5
nikolya5
09.10.2020 11:57
Прикреплена фотография с кодом, тест и сам кодОткрывать любым текстовым редактором
На с++ с циклом white на вход программы подается 10 чисел. выведите в столбик для каждого из них чис
На с++ с циклом white на вход программы подается 10 чисел. выведите в столбик для каждого из них чис
0,0(0 оценок)
Ответ:
qqruzko
qqruzko
09.10.2020 11:57
Решение с массивами

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a[10];

   int i = 0;

   while (i < 10) {

     cin >> a[i];

     ++i;

   }

   i = 0;

   while (i < 10) {

     cout << (2 * a[i] * a[i]) << endl;

     ++i;

   }

   return 0;

}


Решение без массивов (онлайн-вывод)

#include <bits/stdc++.h>

using namespace std;

int main() {

   int x;

   int i = 0;

   while (i < 10) {

     cin >> x;

     cout << (2 * x * x) << endl;

     ++i;

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?