В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kris406
kris406
07.01.2023 23:19 •  Информатика

Hel//helllppp написать программу в паскаль, . в массиве a[1..6] найти сумму положительных элементов, найти сумму положительных элементов, которые которые находятся в диапазоне от -1 до 5 включительно.

Ответ:
elkenakate1221
elkenakate1221
09.10.2020 11:22
PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(6, -10, 10);

 a.Println;

 Writeln('Сумма положительных ', a.Where(t -> t > 0).Sum);

 Writeln('Сумма положительных на [-1;5] ',

   a.Where(t -> (t > 0) and t.InRange(-1, 5)).Sum);

end.

Пример3 -2 -2 7 3 6Сумма положительных 19Сумма положительных на [-1;5] 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?