В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
4977
4977
26.09.2022 22:23 •  Информатика

Напишите программу которая в последовательности натуральных 20 чисел определяет сумму чисел кратных 6 на языке паскаль

Ответ:
Капуста11111
Капуста11111
09.10.2020 10:41
1) Решение с массивами

var

 a: array[1..20] of longint;

 i, sum: longint;

begin

 for i:=1 to 20 do

 begin

   read(a[i]);

   if a[i] mod 6=0 then sum:=sum+a[i];

 end;

 writeln(sum);

end.


Постановка задачи позволяет отказаться от использования массивов и работать только с тремя целочисленными переменными.

2) Решение без массивов

var

 x, i, sum: longint;

begin

 for i:=1 to 20 do

 begin

   read(x);

   if x mod 6=0 then sum:=sum+x;

 end;

 writeln(sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?