В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Юліан11
Юліан11
26.12.2021 13:42 •  Информатика

Написать программу, которая в матрице a(n,m) находят все элементы , равные числу, введённому с клавиатуры. подсчитать числа таких элементов. в dev c++.

Ответ:
DevilingKeks
DevilingKeks
09.10.2020 10:37

#include "stdafx.h"

#include <iostream>

#include <ctime>

using namespace std;

 

int main()

{

srand(time(0));

int n, m, k;

 

cout << "N = ";

cin >> n;

cout << "M = ";

cin >> m;

cout << "K = ";

cin >> k;

 

int A[100][100];

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  A[i][j] = 1 + rand() % 10; // от 1 до 10

 }

}

cout << endl;

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  cout << A[i][j] << " ";

 }

 cout << endl;

}

int temp = 0;

for (int i = 0; i < n; i++)

{

 for (int j = 0; j < m; j++)

 {

  if (A[i][j] == k)

   temp++;

 }

}

cout << temp << endl;

system("pause");

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?