В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Программа на с++: объединение прямоугольников. даны n прямоугольников (n ≤ 10), стороны которых параллельны осям координат, а координаты вершин являются действительными числами. напишите программу, которая вычисляет площадь фигуры, получаемой в результате объединения n прямоугольников. решите .

Ответ:
Оля142768
Оля142768
10.09.2020 22:16

Я так понимаю из задания вы это хотели.

В следующий раз самостоятельно хоть попытайтесь сделать,и приложите ваше решение к вопросу.

#include<iostream>;

using namespace std;

int main()

{

 

int n;

float  height, width,square=0;

cout << "pls enter count rectangle" << endl;

while (true) //Бесконе4ный цикл

{

 cin >> n;

 if (n <= 10 && n > 0)//как нашли-выходим из цикла

  break;

}

 

cout << "pls enter height" << endl;

cin >> height;

cout << "pls enter width" << endl;

cin >> width;

cout << endl;

for (int i = 0; i < n; i++)

{

 square = square + (height * width);

}

cout <<"your answer : "<< square << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?