В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
62620243323
62620243323
26.06.2022 09:00 •  Информатика

C++ написать программу , которая выводит на экран символы (на латинском) не относящиеся к вашему имени к примеру : egor не относящиеся символы: a b c d f h i j k l m p q s t u w y z

Ответ:
Kadokawa
Kadokawa
04.08.2020 21:10

#include <iostream>

#include <string>

#include <cctype>

#include <algorithm>


int main()

{

std::string abc = "";


std::string name;

std::cin >> name;


for (const char &character : name)

{

 abc.erase(std::remove(abc.begin(), abc.end(), tolower(character)), abc.end());

}


for (const char &character : abc)

{

 std::cout << character << ' ';

}

std::cout << std::endl;

return 0;

}

0,0(0 оценок)
Ответ:
Sm112004
Sm112004
04.08.2020 21:10

#include <iostream>

#include <string.h>

using namespace std;

#define MAX 128

char str[MAX], alf[MAX];

int main()

{

puts("Input name: ");

gets(str);

strlwr(str);

for(int i = 0; i <= 'z' - 'a'; i++)  

 alf[i] = 'a' + i;

for(int i = 0; i < strlen(str); i++)

 if ((str[i] >= 'a') && (str[i] <= 'z'))

  alf[str[i] - 'a'] = '0';

cout << "Letters that are not in the name: ";

for(int i = 0; i <= 'z' - 'a'; i++)  

 if (alf[i] != '0')

  cout << alf[i] << " ";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?