В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alex110403
alex110403
03.09.2021 07:57 •  Информатика

Напишите программу, которая заполняет массив из 20 элементов и находит в нём минимальный из чётных элементов и его номер. предполагается, что в массиве есть чётные элементы.

Ответ:
Nelai54
Nelai54
09.10.2020 07:46
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(20, -50, 50);

 a.Println;

 var min := a.Where(t -> t.IsEven).Min;

 var i := a.IndexOf(min);

 Writeln('a[', i + 1, '] = ', min)

end.

Пример

39 -37 21 13 26 1 37 -19 21 39 -34 -23 22 46 8 -6 -21 39 47 32

a[11] = -34

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?