В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
adamchik
adamchik
15.04.2023 18:50 •  Информатика

Напишите программу, которая принимает два вещественных числа, значение для числа десятичных знаков, вычисляет сумму и выводит результат. попробуйте ввести действительное число для числа знаков после запятой.

Ответ:
katy3105
katy3105
09.10.2020 07:29

program Real2;

var

 a, b, d: Real;

 id: Integer;

begin

 Write ('Введите два вещественных числа: ');

 Read (a, b);

 Write ('Введите число знаков после запятой: ');

 Read (d);

 id := Trunc (d);

 WriteLn;

 Write ('Сумма = ', a + b :15 :id);

 ReadLn;

 ReadLn;

end.

Объяснение:

действительное число для количества знаков после запятой вводится в d, затем чтобы использовать его в форматировании вывода преобразуется в целое (id := Trunc (d); ).

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?