В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу которая отобразит числа в порядке пирамиды паскаля. программа должна вычислить и отобразить 15 этажей пирамиды с++

Ответ:
dushka305070
dushka305070
09.10.2020 07:33

#include <iostream>

#include <iomanip>

using namespace std;

#define N 15

#define S 128

int main () {

int mas[S];

for(int n = 0; n < N; n++) {

 mas[0] = 1;

 for(int i = 1; i <= n ; i++)  

  mas[i] = 0;

 for(int i = 1; i <= n; i++)

  for(int j = i; j >= 1; j--)

   mas[j] += mas[j-1];

 cout << setw(2) << n << ":";

 for(int i = 0; i < 35 - 5 * n / 2; i++)

  cout << " ";

 for(int i = 0; i <= n ; i++)

  cout << setw(5) << mas[i];

 cout << endl;

}

   return 0;

}


Напишите программу которая отобразит числа в порядке пирамиды паскаля. программа должна вычислить и
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?