В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Lera11111111100000
Lera11111111100000
31.05.2020 18:26 •  Информатика

Напишите программу в pascal сергей страдает ожирением в процессе голодании он каждую неделю скидывает 3% от предыдущего веса изначально он весил 150 кг в машину он влезет когда будет весить 96 кг через сколько недель он влезет в машину?

Ответ:
Sofiko20017
Sofiko20017
09.10.2020 07:29

VAR  

MASSA:real;

NED:INTEGER;

BEGIN

MASSA:=150;

NED:=0;

WHILE (MASSA>=96) DO

BEGIN

MASSA:=MASSA-MASSA*0.03;

NED:=NED+1;

END;

WRITELN('Через ',NED,' недель Сергей влезет в машину')

END.

0,0(0 оценок)
Ответ:
darina1209
darina1209
09.10.2020 07:29

var v,z:real;

   i:integer;

begin

v:=150;

while not(v<=96) do

begin

z:=(v/100)*3;

v:=v-z;

inc(i);

end;

write(i);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?