Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ученик1523
04.10.2020 18:18 •
Информатика
:дан массив а из 20 чисел. найти элемент, косинус которого минимальный,результаты распечатать в виде а(i)= соs a(i)=
Ответ:
JusticeLeague
09.10.2020 06:49
На Си:
#include <stdio.h>#include <string.h>#include <math.h>#define SIZE 20int main(void) { double a[SIZE]; int i; for (i = 0; i < SIZE; i++) { scanf("%lf", &a[i]); } double max[3]; for (i = 0; i < (SIZE - 1); i++) { if (cos(a[i]) > cos(a[i + 1])) { max[0] = cos(a[i]); max[1] = a[i]; max[2] = i; } } printf("a[%d]=%lf\n", (int) max[2], max[1]); printf("cos a[%d]=%lf\n", (int) max[2], max[0]); return 0;}
0,0
(0 оценок)
Популярные вопросы: Информатика
Shkodinka
25.03.2021 17:16
Решить в паскале в первый день рабочий произвел х деталей. во второй и в последующие дни он увеличивал норму предыдущего дня в 2 раза. сколько деталей он делал каждый...
Irusik55
26.01.2021 22:58
Какова мощность алфавита, с которого записано сообщение, содержащее 6144 символов, если его объем составляет 3/256 мбайта?...
Отличница846
23.08.2022 19:27
Составить программу в pascalabc. составить программу для вычисления стоимости x театральных билетов по 150 руб.и y билетов по 100 руб....
elviraloveelvi
23.08.2022 19:27
Вмешке находятся 512 фруктов: 128 бананов, 256 слив(-ы), 64 апельсина и 64 абрикоса. какое количество информации содержится в сообщениях о том, что из мешка случайным...
Max325t
10.02.2022 21:45
60 . нужно решение не в виде кода задана дата d.m.g. сколько полных кварталов осталось до конца этого года?...
Auebandit1337
23.08.2021 22:49
Определите информационный объём стереоаудиофайла (музыки) в кб длительностью звучания 60 секунд при качестве звука 16 битов, 48 кгц (умножить на 2 т.к. стереозвучание...
Akura12
23.08.2021 04:12
Одна секунда видео содержит 34,25 мб информации . определите объем фильма длительностью 1 час в мегабайтах, а затем переведите в терабайты....
gfjew56df
04.11.2021 14:20
Племена каюмба и гаюмба обменялись сообщениями. у племени каюмба мощность алфавита - 8, а у племени гаюмба - 16. у обоих в сообщении было по 25 знаков. у какого племени...
Рита7373
08.09.2022 09:29
Что делать, когда вам пришло письмо о том, что вы выиграли в лотерею? 1.пометить сообщение как спам 2перейти по ссылке в письме, ведь иногда информация может оказаться...
Pwp790
03.03.2021 03:32
Что делать, когда вам пришло письмо о том, что вы выиграли в лотерею?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
На Си:
#include <stdio.h>#include <string.h>#include <math.h>#define SIZE 20int main(void) { double a[SIZE]; int i; for (i = 0; i < SIZE; i++) { scanf("%lf", &a[i]); } double max[3]; for (i = 0; i < (SIZE - 1); i++) { if (cos(a[i]) > cos(a[i + 1])) { max[0] = cos(a[i]); max[1] = a[i]; max[2] = i; } } printf("a[%d]=%lf\n", (int) max[2], max[1]); printf("cos a[%d]=%lf\n", (int) max[2], max[0]); return 0;}