В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hjr56
hjr56
15.03.2020 12:57 •  Информатика

Написать программу 8 класс в общеобразовательной школе города n решили всем ученикам централизовано выдать логины для доступа к всероссийскому порталу молодёжи. т.к. большинство школьников сложно запоминают набор цифр и букв, многие из них неправильно запомнили свой логин. правильный логин представляет из себя строку, состоящую из двух частей. первая часть это строка из двух букв "io", вторая часть - набор цифр. таким образом логин "io82865" является корректным, а логин "ind3038" - нет. каждый школьник хочет узнать, корректен ли его логин. чтобы не смотреть каждый такой запрос детально, директор школы просит вас написать программу, которая сможет определить корректность логина. формат входного файла: в единственной строке входного файла дана строка s, состоящая из строчных латинских букв и цифр - логин участника. формат выходного файла: в единственной строке выходного файла выделяется correct, если логин корректен для данного контеста. иначе выделяется incorrect/

Ответ:
СэмТV
СэмТV
04.08.2020 20:32

var

  s: string;

  e, tmp: integer;

  mistake: boolean;

   

begin

   

  mistake := true;

   

  write('Введите логин: ');

  readln(s);

   

  if ((s.Length = 7) and (s[1] = 'i') and (s[2] = 'o')) then

  begin

     s := s.Remove(0, 2);

     Val(s, tmp, e);

     

     if (e = 0) then

        mistake := false;

  end;

   

  if (mistake) then

     write('Incorrect')

     

  else

     write('Correct');

end.


Написать программу 8 класс в общеобразовательной школе города n решили всем ученикам централизовано
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?