В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vstef
vstef
11.12.2021 05:18 •  Информатика

Составить программу которое забрашивает четырёхзначное число и находит сумму цифр четырёхзначного числа и определяет делиться на 5.​

Ответ:
anonimm852
anonimm852
09.10.2020 05:25

program numsum;

uses

 SysUtils;

var

 n, i, sn: Integer;

 s: string;

begin

 Write ('Введите четырехзначное число: ');

 ReadLn (n);

 n := Abs (n);

 if (n > 9999) or (n < 1000) then begin

   WriteLn ('Введенное число не четырехзначное');

   ReadLn;

   Exit;

 end;

 s := IntToStr (n);

 sn := 0;

 for i := 1 to Length (s) do

   sn := sn + StrToInt (s [i]);

 WriteLn ('Сумма цифр числа = ', sn);

 if sn mod 5 = 0 then

   WriteLn ('Сумма цифр делится на 5')

 else

   WriteLn ('Сумма цифр не делится на 5');

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?