В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
evgeniya64
evgeniya64
30.04.2023 15:56 •  Информатика

Составьте программу, которая вычисляет произведение чисел от 1 до n. число n вводится с клавиатуры. с++

Ответ:
Заяц699
Заяц699
09.10.2020 04:59
Код

#include <iostream>

using namespace std;

int main()

{

   // 1*2*3*4*5*6*7*8*9*10 = 3628800

   setlocale(LC_ALL, "Russian");

   unsigned int N;

   long long int Result = 1;

   cin >> N;

    for(int i = 1; i <= N; i++){

       Result = Result * i;

   }

   cout << endl << Result;

   return 0;

}

Проверка

10

3628800


5

120

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?