В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sabr1nka
sabr1nka
04.07.2022 00:33 •  Информатика

Написать программу, запрашивающую пять чисел и суммирующию только положительные из них. значение суммы вывести на экран.

Ответ:
vlad0805
vlad0805
09.10.2020 04:34

uses crt;

const n=5;

var a:array[1..n] of integer;

   s,i:integer;

begin

    for i:=1 to n do

    read(a[i]);

    for i:=1 to n do

    write(a[i]:3);

    for i:=1 to n do

    begin

         if (a[i]>0)and(a[i]<>0) then s:=s+a[i];

    end;

    writeln;

    write(s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?