В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Baka1111
Baka1111
12.05.2021 12:43 •  Информатика

Написать программу на pascalabc. найдите положительные и отрицательные целые числа в заданном численном значении n и определите сумму абсолютных значений.

Ответ:
Натама
Натама
09.10.2020 02:56
PascalABC.NET 3.4.2, сборка 1827 от 08.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(ReadInteger('n='), -50, 50);

 a.Println;

 Writeln('Сумма отрицательных чисел равна ', a.Where(t -> t < 0).Sum);

 Writeln('Сумма положительных чисел равна ', a.Where(t -> t > 0).Sum);

 Write('Максимальное по модулю число ');

 var (m1, m2) := (a.Min, a.Max);

 if Abs(m1) > Abs(m2) then m1.Println

 else m2.Println

end.


Написать программу на pascalabc. найдите положительные и отрицательные целые числа в заданном числен
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?