В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ArinaGaGara
ArinaGaGara
21.05.2023 17:19 •  Информатика

Написать программу на языке pascal ! задана окружность с центром в точке о (x0, y0) и радиусом r0. определить пересекается ли заданная окружность с осью абсцисс, если пересекается найти точки пересечения.

Ответ:
sasha11225
sasha11225
02.09.2020 10:19

var x0, y0, r0, x1, x2:real;

begin

readln(x0,y0,r0);

// уравнение окружности: (x-x0)^2+(y-y0)^2=r0^2

if r0*r0-y0*y0>=0 then

begin

x1:=-sqrt(r0*r0-y0*y0)+x0;

x2:=sqrt(r0*r0-y0*y0)+x0;

writeln('Точки пересечения: x1 = ',x1:4:2,' x2 = ',x2:4:2);

end

else writeln('Не пересекается');

end.

Пример:

1 1 2

Точки пересечения: x1 = -0.73 x2 = 2.73

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?