В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Саша22122004
Саша22122004
14.08.2020 14:25 •  Информатика

Двумерные массивы. сам.работа вар.2 с-14 1.составьте программу вычисления суммы отрицательных элементов матрицы a(n,n) 2.составьте программу вычисления произведения положительных элементов матрицы b(n,n) 3.cоставьте программу
вычисления суммы элементов третьего столбца матрицы с(n,n) решите (

Ответ:
dimaolegon96
dimaolegon96
24.05.2020 02:49

var a,b,c:array [1..100,1..100] of integer;

as,bs,cs,i,j:integer;

Begin

  sb:=1;

  for i := 1 to n do

     for j:= 1 to n do

     begin

       if a[i,j]<0 then sa:=sa+a[i,j];

       if b[i,j]>0 then sb:=sb*b[i,j];

       if j=3 then sc:=sc+c[i,j];

     end;

   writeln(sa,sb,sc);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?