В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
122519
122519
30.05.2022 13:54 •  Информатика

Требуется написать программу, которая будет выполнять действия описанные ниже. желательно с комментированием.(visual studio, на c#) символы и их коды. формирование строк 1.16. дана строка. преобразовать в ней все прописные латинские буквы в строчные. 1.17. дана строка. преобразовать в ней все строчные буквы (как латинские, так и ) в прописные. 1.18. дана строка. преобразовать в ней все строчные буквы (как латинские, так и ) в прописные, а прописные — в строчные.

Ответ:
Savasansa
Savasansa
09.10.2020 02:13

Переменную строки буду называть \texttt{str}.

1.16.

\texttt{Console.WriteLine(new String(}\\\texttt{{ }{ }{ }{ }str}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = t.ToString())}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = Regex.IsMatch(t, @"[A-Z]") ? t.ToLower() : t)}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = t.First())}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.ToArray()));}

1.17.

\texttt{var regex = @"[a-z,}а-я\texttt{]";}

\texttt{Console.WriteLine(new String(}\\\texttt{{ }{ }{ }{ }str}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = t.ToString())}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = Regex.IsMatch(t, regex) ? t.ToUpper() : t)}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = t.First())}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.ToArray()));}

1.18.

\texttt{Console.WriteLine(new String(}\\\texttt{{ }{ }{ }{ }str}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = t.ToString())}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = }\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }char.IsLower(t.First()) ? t.ToUpper() :}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }char.IsUpper(t.First()) ? t.ToLower() :}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }{ }t)}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.Select(t = t.First())}\\\texttt{{ }{ }{ }{ }{ }{ }{ }{ }.ToArray()));}

Потребуется использовать

\texttt{using System.Linq;}

\texttt{using System.Text.RegularExpressions;}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?