В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу в c напишите программу, которая считывает значения двух переменных a и b, затем меняет их значения местами (в переменной a должно быть записано то, что раньше хранилось в b, и наоборот) решением не является такой вид: ввод (a) ввод (b) вывод (b, a) вводится два целых числа

Ответ:
leski
leski
09.10.2020 01:18

#include <stdio.h>

void swap(float& a, float&b)

{

float tmp = a;

b = a;

a = tmp;

}

int main()

{

float a, b;

scanf_s("%f%f", &a, &b);

printf("%f %f", a, b);

swap(a, b);

printf("%f %f", a, b);

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?