В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
панда267
панда267
09.03.2020 19:27 •  Информатика

Написать программу паскаль вообще не шарю в программах,а так 2 ! «a»: ввести натуральное число и найти сумму его цифр. пример: введите натуральное число: 12345. сумма цифр 15. «b»: ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. пример: введите натуральное число: 12342 нет. пример: введите натуральное число: 12245 да.

Ответ:
Sazon1000
Sazon1000
09.10.2020 01:12

A)

var num, sum, i, temp: Integer;


begin


print('Number: ');


readln(num);


temp:= num;


i:=1;


while(temp <> 0) do


 begin


 temp:= temp div 10;


 if(temp =0) then break;


 i:= i+1;


 end;


temp:= i;


sum:=0;


for i:=0 to temp do


 begin


 sum:= sum + (num mod 10);


 num:= num div 10;


 end;


println('Sum: ',sum);


end.


B)


var num, temp: Integer;

   bool:boolean;    

begin

readln(num);

temp := num mod 10;

num := num div 10;

while(num<>0) do

 begin

 if (temp = num mod 10)  

   then

   begin

   bool:=true;

   break;

   end;

 temp := num mod 10;

 num := num div 10;

 end;

if bool then write('Yes') else write('No');

end.

0,0(0 оценок)
Ответ:
Tokalexandra
Tokalexandra
09.10.2020 01:12

begin

 var s := ReadString('n =');

 s.Aggregate(0, (Sum, x)-> Sum + x.toDigit).Println;

 

 var i := 2;

 while (i <= s.Length) and (s[i] <> s[i - 1]) do i += 1;

 

 Print(i > s.Length ? 'No' : 'Yes')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?