В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KSUMOKLOKOVA
KSUMOKLOKOVA
21.12.2020 10:18 •  Информатика

Паскаль. попроще. дано трехзначное число. написать программу, позволяющую вывести на экран сумму его цифр.

Ответ:
нина12789
нина12789
09.10.2020 01:10

var

 d, k: integer;

begin

 write('Запишите число: ');

 readln(d);

 while d > 0 do  

 begin

   k := k + (d mod 10);

   d := d div 10;

 end;

 writeln(k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?