В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ntt1
Ntt1
01.11.2022 01:48 •  Информатика

C++ напишите программу, которая запрашивает пять целых чисел и выводит в первой строке сумму первых двух чисел, во второй строке -- сумму первых трёх чисел, в третьей строке -- сумму первых четырёх чисел, в четвёртой строке -- сумму всех пяти чисел. заранее !

Ответ:
anchertow
anchertow
09.10.2020 00:59

#include <array>

#include <iostream>

#include <algorithm>

#include <numeric>

#include <iterator>

int main()

{

   std::array<int, 5> arr;

   std::generate(arr.begin(), arr.end(), []()

   {

       return 1 + std::rand() % 100;

   });

   std::copy(arr.begin(), arr.end(),

       std::ostream_iterator<int>(std::cout, " "));


   std::cout << std::endl << std::accumulate(arr.begin(), arr.end()-3, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end()-2, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end()-1, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end(), 0) << std::endl;

}


C++ напишите программу, которая запрашивает пять целых чисел и выводит в первой строке сумму первых
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?