В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
wjwjwjeuei
wjwjwjeuei
03.01.2023 17:41 •  Информатика

Составить программу в паскаль. вывести на экран произведение первых 20-ти натуральных чисел. нужно. заранее ! )

Ответ:
KSUMOKLOKOVA
KSUMOKLOKOVA
08.10.2020 23:50

Типа double должно хватить под это все дело.

В целочисленные типы такое число, увы, не влезет.

var

   i:integer;

   result:double;

begin

   result := 1;

   for i := 2 to 20 do

       result := result * i;

   writeln('Результат = ', result);

end.

0,0(0 оценок)
Ответ:
MrtMiyaGi
MrtMiyaGi
08.10.2020 23:50

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018


begin

 Range(1,20).Aggregate(biginteger(1),(p,x) -> p*x).Println;

end.


ответ =  2432902008176640000

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?