В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Pavel1810
Pavel1810
13.04.2022 12:56 •  Информатика

Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x< -10 и b неравно 0; (x/(x- при x> 0 и b=0; -(|x|*x^2)/c в остальных случаях}

Ответ:
настя06032005
настя06032005
16.08.2020 23:51

#include <iostream>

#include <iomanip>

#include <cmath>


int main()

{

float

 a, b, c, x,

 f = 0.0f;

std::cout << "Введите значения переменных A, B, C, X: ";

std::cin >> a >> b >> c >> x;


if(x < - 10 && b != 0)

 f = -a * pow(x, 2) + pow(b, 3);

else if(x > 0 && b == 0)

 f = x / ((x-c) - a);

else f = -(abs(x) * pow(x, 2)) / c;


std::cout << "Значение переменной f = " << std::setprecision(3) << f << std::endl;

}

g++ compiler

В общем, я не знал, как сохранить блок-схему в фотку, поэтому держи так. Просто срисуй, если нужно. Уж извиняй :)


Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x<
Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x<
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?