В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ahmad7froukhp00vlz
ahmad7froukhp00vlz
04.02.2020 19:46 •  Информатика

Написать программу с++, создать матрицу, заполнить рандомными числами,найти максимальный элемент в главной диагонали

Ответ:
vifi
vifi
08.10.2020 23:10

#include <iostream>

#include <cstdlib>

#include <ctime>

int main()

{

   int N;

   

   std::cout << "Введите количество строк и столбцов(N): ";

   std::cin >> N;

   

   //выделяем память

   int** arr = new int* [N];

   for(int i = 0; i < N; i++)

       arr[i] = new int [N];

   

   srand(time(NULL));//рандомизация

   

   std::cout << "Матрица имеет вид: " << std::endl;

   //заполняем массив случайными числами

   for(int i = 0; i < N; i++)

   {

       for(int j = 0; j < N; j++)

       {

           arr[i][j] = 1 + rand() % 100; // от 1 до 100

           std::cout << arr[i][j] << " ";

       }

       std::cout << std::endl;

   }

   

   //ищем максимальное число

   int max = arr[0][0];

   for(int i = 0, j = 0; i < N, j < N; i++, j++)

   {

       if(arr[i][j] > max)

           max = arr[i][j];

   }

   

   std::cout << std::endl << "Наибольшее число на главной диагонали: " << max;

   

   //удаляем память

   for(int i = 0; i < N; i++)

       delete[] arr[i];

   delete[] arr;    

   

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?