В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
panyaeva06
panyaeva06
21.11.2022 14:48 •  Информатика

Составить программу, которая вычисляет площадь прямоугольного треугольника. пользователь вводит с клавиатуры 1 катет и гипотенузу. при выводе результата должно быть обеспечено 2 знака после запятой.

Ответ:
12abgh
12abgh
16.08.2020 23:23

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var (a, c) := ReadReal2('Введите через пробел катет и гипотенузу:');

 if a > c then Swap(a, c);

 Writeln('Площадь треугольника равна ',

     0.5 * a * Sqrt(Abs(c * c - a * a)):0:2)

end.

0,0(0 оценок)
Ответ:
Cheter22871
Cheter22871
16.08.2020 23:23

begin

 var a, c: real;

 repeat

   a := ReadlnReal('введите катет, a =');

   c := ReadlnReal('введите гипотенузу, c =');

   if a >= c then Println('гипотенуза должна быть больше катета')

 until c > a;

 var S := 0.5 * a * Sqrt(c * c - a * a);

 Write('Площадь прямоугольного треугольника: S = ', S:0:2)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?