В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
LyVlAr
LyVlAr
18.04.2020 17:04 •  Информатика

Напишите программу pascal - 1*(1+2)*(1+2+3)*(1+2+3+4)*(1+2+3+)

Ответ:
vladlena24
vladlena24
16.08.2020 23:22

var  

   N:integer;

   i:integer;

   sum:integer;

   result:integer;


begin

   writeln('Введите значение N:');

   readLn(N);

   

   sum := 0;     result := 1;


   for i := 1 to N do

   begin

       sum := sum + i;

       result := sum * result;

   end;

   writeln('Конечное значение = ', result);

end.

0,0(0 оценок)
Ответ:
Chvik
Chvik
16.08.2020 23:22

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!


begin

 var (m,n):=(3,ReadInteger('n ='));

 SeqGen(n-1,m,t->begin Result:=t+m; m+=1 end)

     .Aggregate(BigInteger(1),(p,q)->p*q).Println

end.

---------------------------

n = 5

2700

--------------------------

n = 92

2905717351708908985405643744987697767130796956644732769142761496541317116624931720391311988753812039943077115478561297954388733569194661753822436538090873756174074892748228397527408937781819534979620536526957830995968000000000000000000000000000000000000000000


Напишите программу pascal - 1*(1+2)*(1+2+3)*(1+2+3+4)*(1+2+3+)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?