В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lavbi3
lavbi3
20.09.2020 18:14 •  Информатика

Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр введенного натурального числа четной или нечетной.

Ответ:
Сложное123
Сложное123
08.10.2020 22:04

#include <iostream>

int main() {

   std::string s;

   int S = 0;

   std::cin >> s;

   for (int i=0; i<s.length(); i++){

       S += int(s[i]-'0');

   }

   std::cout<<(S%2?"Odd":"Even");

   return 0;

}

Объяснение:


Составить блок схему и написать программу на языке с++. с цикла определите является ли сумма цифр вв
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?