Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
CheryLi
23.05.2021 02:47 •
Информатика
Напишите программу, при которой можно подсчитать расходы на доставку мебели. исходные данные для расчета – номер этажа и информация о наличии и типе лифта (грузовой или обычный). c++
Ответ:
высшийразум68
08.10.2020 21:37
Надеюсь без ошибок. Цену за отдельные аспекты назначте сами:
#include stdlib.h
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";
cout <<"\n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
kedr3
20.09.2020 23:15
Составить программу на паскале.заданы длины сторон трех треугольников.найти больший периметр.для вычисления периметра треугольника используйте процедуру perimetr,для определения...
TemaKorol190803ru
03.05.2021 04:46
Определите, что будет напечатано в результате выполнения следующей программы: program a7; var i,s: integer; sr: real; const a: array [1..6] of integer=(1, 7, 3,6,0,10); begin s:...
TyTToŪLLlkoJlbHuK
03.05.2021 04:46
Статья, набранная на компьютере, содержит 32 страницы, на каждой страницы 32 строки, в каждой строке 25 символов. определите информационный объём статьи в кодировке windows-1251...
кики50
03.05.2021 04:46
Вэлектронной таблице значение формулы =сумм(b1: b5) равно 24.чему равно значение ячейки b6,если значение формулы = срзнач (b1: b6) равно 4?...
erasil1105
19.05.2020 21:53
От какого параметра зависит качество изображения?...
Роли5
28.04.2023 12:12
Надо сфера применения: мини эвм сфера применения: рабочих станций сфера применения: микро эвм...
Police222
25.03.2023 03:03
1. pascal. даны три точки a(x1,y1), b(x2,y2), c(x3,y3). написать программу, определяющую, которая из точек находится ближе к началу координат....
Александраlove1
25.03.2023 03:03
Дан массив, элементы которого заданы датчиком случайных чисел на интервале [-20, 25]. размер массива произвольный. найти наименьший элемент в массиве и его порядковый номер....
кВіТкА9876565446
05.06.2020 08:40
Составить блок-схему алгоритма и программу вычисления суммы всех двузначных чисел, оканчивающихся на цифру 7 (на pascalabc)...
4443468234763399
26.12.2022 02:56
Найдите значение выражения 49-(14+c) при c=13...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include stdlib.h
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";
cout <<"\n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}