В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
буря4
буря4
27.04.2021 01:49 •  Информатика

Написать программу на языке pascal (цикл for и while ). найти сумму нечетных чисел в промежутке от 20 до n

Ответ:
Damir2342
Damir2342
08.10.2020 21:23

Program l;

var

i, n, s: integer;

begin

writeln('Введите n');

readln(n);

for i = 20 to n do begin

if (i mod 2 <> 0) then

s := s + i;

end;

write(s);

end.

0,0(0 оценок)
Ответ:
maximb164mjqj
maximb164mjqj
08.10.2020 21:23
Var
  i,n,s:integer;
begin
  Write('n=');
  Readln(n);
  s:=0;
  for i:=20 to n do
    if Odd(i) then s:=s+i;
  Writeln('Сумма с for = ',s);
  s:=0; i:=21;
  while i<=n do
  begin
    s:=s+i;
    i:=i+2
  end;
  Writeln('Сумма с while = ',s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?