Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
nikoszahar
10.08.2021 00:17 •
Информатика
Написать подпрограмму возведения любого числа в целую неотрицательную степень. с ее вычислить, сколько байтов содержится в килобайте, мегабайте и в гигабайте. pascal abc
Ответ:
Annakitte0
08.10.2020 21:17
Function Pow(m,n:integer):longint;
var
i:byte;
p:longint;
begin
p:=1;
for i:=1 to n do p:=p*m;
Pow:=p
end;
begin
Writeln('1 Кбайт=',Pow(2,10),' байт');
Writeln('1 Мбайт=',Pow(2,20),' байт');
Writeln('1 Гбайт=',Pow(2,30),' байт');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ассасин32
10.02.2022 04:13
Во вложении что общего?? ...
SekretKtoYa
09.07.2022 01:06
. написать программу,. Если произведение трёх чисел больше или равно 120, то программа прибавляет к этому произведению 100. если меньше 120, то прибавляет 1000....
zlatochkagr
01.02.2022 01:04
Язык программирования Паскаль,тема цикл с постусловием( UNTIL) и цикл с предусловием люди очень надо:(...
0mixa0
21.03.2021 08:20
В книге 128 страниц, на каждой странице 32 строки, в каждой строке 16 символов. Определите объем информации всей книги, если один символ кодируется 2 байтами, ответ дайте в килобайтах...
BC122
20.09.2021 15:56
с заданием, желательно с решением ,заранее...
LionRed225
12.06.2021 19:46
Пользовательский интерфейс надо нарисовать пользовательский интерфейс компьютера, я не знаю что нарисовать подскажите что можно (заранее )...
daramarkel
16.10.2022 15:16
Дан массив целых чисел из 12 элементов. к сумме первых 8 прибавить произведение последних 7 элементов....
Ландыш098
02.08.2022 03:10
Дан массив целых чисел из 12 элементов. найти количество элементов массива являющихся кратными трем и пяти....
Mockingbird666
13.05.2022 12:19
Визначте, які оператори реалізують дію: Знайти суму перших десяти натуральних чисел. Позначте всі правильні відповіді. * Whіle i = 10 do begin A := A+1; S := S+i end; if A 10 then...
150819761
29.11.2020 07:26
Посчитать сколько раз в данной строке встречается символ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
i:byte;
p:longint;
begin
p:=1;
for i:=1 to n do p:=p*m;
Pow:=p
end;
begin
Writeln('1 Кбайт=',Pow(2,10),' байт');
Writeln('1 Мбайт=',Pow(2,20),' байт');
Writeln('1 Гбайт=',Pow(2,30),' байт');
end.