В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
dasha5010
dasha5010
02.06.2022 00:12 •  Информатика

Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. pascal abc

Ответ:
алина3798
алина3798
08.10.2020 21:14

var

    s: string;


function Invert(s: string): string;

var

    i: integer;

    t: string;

begin

    t := '';

    for i := 1 to length(s) do

        t := s[i] + t;

    

    Invert := t;

end;


begin

    Write('Введите слово: ');

    Readln(s);

    

    s := Trim(s);

    s := Uppercase(s);

    

    if Invert(s) = s then 

        Writeln('Палиндром')

    else 

        Writeln('Не палиндром');

end.

0,0(0 оценок)
Ответ:
armvos
armvos
08.10.2020 21:14
Var
  s:string;
  i,n:byte;
  p:boolean;
begin
  Write('Введите слово: ');
  Readln(s);
  n:=Length(s);
  p:=true;
  for i:=1 to n div 2 do
    if s[i]<>s[n-i+1] then
    begin
      p:=false;
      break
    end;
  if p then Writeln('Палиндром')
  else Writeln('Не палиндром')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?