В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
никтма
никтма
02.06.2022 00:12 •  Информатика

Написать программу, которая выводит пример на умножение двух однозначных чисел, которые выбираются случайным образом, запрашивает ответ пользователя, проверяет его и выводит сообщение «правильно! » или «вы ошиблись» и верный результат. pascal abc

Ответ:
00Рахат00
00Рахат00
08.10.2020 21:14
Var
  a,b,r:byte;
begin
  randomize;
  a:=Random(9)+1;
  b:=Random(9)+1;
  Write(a,' x ',b,' = ');
  Readln(r);
  if r=a*b then Writeln('Правильно!')
  else Writeln('Вы ошиблись. Верный результат ',a*b)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?