В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Esenbekmalika30
Esenbekmalika30
29.09.2022 23:45 •  Информатика

Нужно написать программу на паскале: в матрице размера m×n положительные элементы заменить единицей. создание и вывод матриц оформить в виде процедур.

Ответ:
тчочолаовов1
тчочолаовов1
16.08.2020 22:48
PascalABC.NET 3.4.0, сборка 1675 от 12.06.2018
Внимание! Если программа не работает, обновите версию!

procedure MatrixCreate(m,n:integer; var A:array[,] of integer);
begin
  A:=MatrRandom(m,n,-50,50);
end;

procedure MatrixOutput(A:array[,] of integer);
begin
  A.Println(4)
end;

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
  var a:array[,] of integer;
  MatrixCreate(m,n,a);
  Writeln('*** Исходная матрица ***');
  MatrixOutput(a);
  a.Transform(t->t>0?1:t);
  Writeln('*** Полученная матрица ***');
  MatrixOutput(a);
end.

Нужно написать программу на паскале: в матрице размера m×n положительные элементы заменить единицей.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?