В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aygulmurzanaev
aygulmurzanaev
05.03.2022 22:13 •  Информатика

Написать программу на языке программирования паскаль. сведения о товарах включают: название, цену, количество и фирму-поставщика. описать данные в виде записи, создать файл из нескольких записей и напечатать, какие товары поставляет данная фирма.

Ответ:
Aly6000
Aly6000
08.10.2020 20:55
PascalABC.NET 3.4.0, сборка 1672 от 10.06.2018
Внимание! Если программа не работает, обновите версию!

type
  tТовар=record
    Название:string[32];
    Цена:real;
    Количество:real; // может быть в килограммах или тоннах
    Поставщик:string[32]
    end;

begin
  var b:tТовар;
  var f:file of tТовар;
  // создаем (или чистим), а затем заполняем файл
  Rewrite(f,'Товары.typ');
  loop ReadlnInteger('Количество товаров:') do begin
    Writeln('Введите информацию по очередному товару');
    b.Название:=ReadlnString('Название:');
    (b.Цена,b.Количество):=ReadlnReal2('Цена товара и его количество:');
    b.Поставщик:=ReadlnString('Поставщик:');
    Write(f,b)
    end;
  f.Close;
  // работаем с файлом
  Reset(f);
  var nf:=Trim(ReadlnString('Какой поставщик интересует?'));
  while not eof(f) do begin
    Read(f,b);
    if Trim(b.Поставщик)=nf then
      Println(b.Название,b.Цена,b.Количество)
    end;
  f.Close
end.

Написать программу на языке программирования паскаль. сведения о товарах включают: название, цену, к
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?