В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vika200458
vika200458
19.04.2020 23:37 •  Информатика

Информатика,паскаль,написать программу: сформировать массив, состоящий из n целых элементов, лежащих в промежутке [10; 10] вычислить: -минимальный по модулю элемент - количество элементов кратных 5 - сумму элементов массива, расположенных между первым и последним положительными элементами.

Ответ:
аграил9
аграил9
08.10.2020 20:52
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
  Writeln('Минимальный по модулю элемент равен ',
      a.Select(t->Abs(t)).Min);
  Writeln('Количество элементов, кратных 5, равно ',
      a.Where(t->t mod 5=0).Count);
  Write('Сумма искомых элементов равна ');
  var ai:=a.Indexesof(t->t>0);
  a[ai.First+1:ai.Last].Sum.Println;
end.

Информатика,паскаль,написать программу: сформировать массив, состоящий из n целых элементов, лежащих
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?