В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
4Z1GGeR4
4Z1GGeR4
07.12.2020 13:45 •  Информатика

Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольника. напишите программу так чтобы любое число могло быть гипотенузой. паскаль

Ответ:
акл2
акл2
08.10.2020 20:51
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqInteger('Введите стороны прямоугольника',3).Sorted.ToArray;
  if Sqr(a[2])=Sqr(a[0])+Sqr(a[1]) then Writeln('Могут')
  else Writeln('Не могут')
end.

Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольн
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?