В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mikiliki889
mikiliki889
23.08.2021 08:04 •  Информатика

Напишите программу, которая будет менять местами в каждой строке двумерного массива минимальный и последний элемент.

Ответ:
FTA72артем
FTA72артем
08.10.2020 20:38
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(m,n,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  for var i:=0 to a.RowCount-1 do begin
    var row:=a.Row(i);
    var imin:=row.IndexMin;
    Swap(row[imin],row[row.High]);
    a.SetRow(i,row)
    end;
  Writeln('*** Полученный массив ***'); a.Println(4)
end.

Напишите программу, которая будет менять местами в каждой строке двумерного массива минимальный и по
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?