В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
qawsed123
qawsed123
27.09.2020 13:12 •  Информатика

Составить программу для : ввести трехзначное число, и вывести через запятую его отдельные цифры.pascal

Ответ:
кулл4
кулл4
08.10.2020 20:28
PascalABC.NET 3.4.0, сборка 1670 от 23.05.2018
Внимание! Если программа не работает, обновите версию!

1. Самое простое "арифметическое" решение

begin
  var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
  Writeln(n div 100,',',(n div 10) mod 10,',',n mod 10)
end.

Пример
n= 318
3,1,8

2. "Арифметическое" решение с циклом, цифры в обратном порядке

begin
  var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
  while n>10 do begin
    Write(n mod 10,',');
    n:=n div 10
    end;
  Writeln(n mod 10)
end.

Пример
n= 318
8,1,3

3. "Арифметическое" решение с массивом

begin
  var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
  var a:array[1..3] of integer;
  var i:=3;
  while n>0 do begin
    a[i]:=n mod 10;
    i-=1;
    n:=n div 10
    end;
  Writeln(a[1],',',a[2],',',a[3])
end.

Пример
n= 318
3,1,8

4. Решение с символьной строкой

begin
  Abs(ReadInteger('n=')).ToString.ToCharArray.Println(',')
end.

Пример
n= 318
3,1,8
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?