Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
13Андрей1311
28.11.2020 01:47 •
Информатика
Заполните массив (15) случайными числами в интервале [0,100] и найдите среднее арифметическое его значений. на языке паскаль, , : )
Ответ:
BrenderMaster
08.10.2020 20:03
PascalABC.NET 3.4.0, сборка 1670 от 23.05.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(15,0,100); a.Println;
a.Average.Println
end.
Пример
65 11 46 1 81 74 17 45 5 79 92 10 39 41 42
43.2
0,0
(0 оценок)
Ответ:
MrRobik
08.10.2020 20:03
Var a: array [1..15] of integer;
i,s:integer;
begin
for i:=1 to 15 do
begin
a[i]:=random (101);
write (a[i],' ');
s:=s+a[i]
end;
writeln;
writeln ('Среднее арифметическое ',s/15)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
вопрос65378
30.11.2022 15:13
Когда я писала ответ , свет выключился . а ответ не сохранился.мне жаль, потому что я дописывала сочинение ( о временах года. у спрашивающего любимое время было лето). вопрос:...
kiki121
01.09.2021 08:33
Служебное слово раздела операторов: служебное слово раздел переменных:...
lubavoytenko003
25.04.2021 03:14
Определите сумму трехзначных чисел кратных 7...
Babetta51
05.07.2022 04:26
Определите сумму трехзначных чисел кратных 7 сделать программу в паскале...
ksysha98090909
05.07.2022 04:26
Выведите на экран натуральные числа на экран в диапазоне с 57 до 96 последовательно через запятую программу сделать в паскале...
dayanocha0080
05.07.2022 04:26
Решить : пять домов стоят вдоль дороги, один за другим. 1. доцент живёт в красном доме. 2. гробовщик держит собак. 3. сантехник пьёт чай. 4. зелёный дом слева от белого. 5. хозяин...
ОдиннидО
05.07.2022 04:26
Перевидете числа из двоичной систему в десятичрую систему счисления : 1101111 , 1111101, 1100011, 1110001...
Щебестан1337
01.04.2021 03:14
Заданы два числа. напишите программу для нахождения частного этих чисел. округлите результат до десятых, оставив в дробной части одну цифру....
valera555132
01.04.2021 03:14
Выведите на экран последовательно числа вида (2i)/(2i-1), не превосходящих числа а (введенного с клавиатуры) программу сделать в паскале...
vd89084999583
10.07.2022 17:19
с ДЗ. Pascal ABC Задание на фото....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(15,0,100); a.Println;
a.Average.Println
end.
Пример
65 11 46 1 81 74 17 45 5 79 92 10 39 41 42
43.2
i,s:integer;
begin
for i:=1 to 15 do
begin
a[i]:=random (101);
write (a[i],' ');
s:=s+a[i]
end;
writeln;
writeln ('Среднее арифметическое ',s/15)
end.