В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mirgin2002
mirgin2002
10.04.2021 18:31 •  Информатика

Дана последовательность из n произвольных целых чисел. написать программу, которая определяет, сколько в этой последовательности отрицательных чисел, кратных 7 (использовать все три вида цикла for, while, repeat)

Ответ:
nargis84002
nargis84002
11.08.2020 07:19
Program SomeProgram;var a : array[0..3] of Integer = (1,7,-7,-14);    i : integer;    count : integer = 0;begin
    // с возможно вам нужно с обычного for    for i in a do begin        if ((i div 7) < 0 ) then begin            count := count + 1;        end;    end;    writeln('(for) количество подходящих чисел: ', count);        // с количество подходящих чисел: ', count);        // с тут главное правльно поставить условие после until    i := 0;    count := 0;    repeat        if ((a[i] div 7) < 0) then        begin            count := count + 1;        end;        i := i + 1;    until i = length(a);    writeln('(repeat until) количество подходящих чисел: ', count);    end.

Дана последовательность из n произвольных целых чисел. написать программу, которая определяет, сколь
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?