В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
silonte
silonte
26.03.2022 13:30 •  Информатика

Напишите программу в паскале, которая высчитывает средний оценок (нужно чтобы в программу можно было вводить хоть сколько оценок).

Ответ:
katya1172
katya1172
08.10.2020 19:31
Program p1;
var 
i,j,s:integer; 
r: double; 
a:array [1..9999] of integer;
begin
writeln('Запишите кол-во оценок');
read(j);
for i:=1 to j do 
begin 
writeln('Введите оценку #', i); 
read (a[i]); 
end;
for i:=1 to j do 
begin 
s:=a[i]+s; 
end; 
writeln('сумма оценок = ', s);
r:=s/j;
writeln('Средний бал = ',r);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?