В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Лолита171107
Лолита171107
03.01.2021 17:39 •  Информатика

Напишите программу в pascal дано трехзначное число х. если х-четное число, то вычислить сумму цифр этого числа. если х-нечетное, то вычислить число-перевертыш

Ответ:
gmurzakaevap06yh1
gmurzakaevap06yh1
08.10.2020 19:29
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var (s,d,e):=(n div 100, n div 10 mod 10,n mod 10);
  if n.IsEven then Writeln(s+d+e) else Writeln(e,d,s)
end.

Примеры
n= 531
135

n= 428
14
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?